Логические операции

При разработке в коде 1С, как и в других языках программирования есть конструкции, результатом вычисления которых будет «ИСТИНА» или «ЛОЖЬ». Необходимо для того, чтобы быстро ориентироваться при построении циклов, разобраться с тем, как будет вести себя результат выполнения кода.

Таблица конъюнкции и дизъюнкции

&НаСервере
Процедура ИзучениеЛогическихОпераций

ТекущийПользователь = Справочники.Пользователи.НайтиПоНаименованию(Администратор);

Администратор = Справочники.Пользователи.НайтиПоНаименованию(Администратор);
Бухгалтер = Справочники.Пользователи.НайтиПоНаименованию(Бухгалтер);

Если (ТекущийПользователь = Администратор) И (ТекущийПользователь = Бухгалтер)

Тогда
Сообщить («1 и 0 = ЛОЖЬ»);
КонецЕсли;

Если (ТекущийПользователь = Администратор) ИЛИ (ТекущийПользователь = Бухгалтер)

Тогда
Сообщить («1 или 0 = ИСТИНА»);
КонецЕсли;

Если (ТекущийПользователь = Администратор) И (ТекущийПользователь = НЕ Бухгалтер)

Тогда
Сообщить («1 и 1 = ИСТИНА»);
КонецЕсли;

Если (ТекущийПользователь = НЕ Администратор) ИЛИ (ТекущийПользователь = Бухгалтер) Тогда
Сообщить («0 или 0 = ЛОЖЬ»);
КонецЕсли;

КонецПроцедуры

Оставить комментарий: