1c циклы

В программе 1С используются стандартные циклы (как и в других языках программирования), которые помогут написать практически любые решения для задач обработки информации. Приведем примеры и код для каждого из них.

1. Цикл для пересчета элементов построчно.

// Вместо «счетчик», может быть любая другая переменная

Для счетчик=1 по 5 Цикл

    Сообщить (Счетчик);

КонецЦикла;

2. Цикл для обхода коллекции значений.

ДниНедели= Новый Массив();

ДниНедели.Добавить(«Четверг»);

ДниНедели.Добавить(«Пятница»);

Для Каждого Элемент Из ДниНедели Цикл

    Сообщить(Элемент); // Четверг, Пятница

КонецЦикла;

3. Цикл с условием, пока значение не станет истинным. Часто используется для получения данных из «выборки» (Выборка.Следующий()).

А= 25;

Пока А<15 Цикл

    А=А-1;

    Сообщить(А);

КонецЦикла;

Если необходимо пропустить итерацию цикла, нужно использовать ключевое слово «Продолжить». Для того, чтобы прервать цикл используется ключевое слово «Прервать». 

Также можно запустить циклы в обратном направлении или же в обратном порядке, но это уже более усложненные варианты. 

Оставить комментарий: