Перевод ТаблицыЗначений в ДеревоЗначений

Обычные формы, версия платформы 8.2.

Функция ВыгрузитьТаблицуЗначенийВДеревоЗначений(Таблица, КлючСтроки = «КлючСтроки», КлючСвязи = «КлючСвязи») Экспорт

Дерево = Новый ДеревоЗначений;
Для Каждого Колонка Из Таблица.Колонки Цикл
Дерево.Колонки.Добавить(Колонка.Имя, Колонка.ТипЗначения);
КонецЦикла;

Для Каждого СтрокаТаблицы Из Таблица Цикл
СтрокаГруппировки = Дерево.Строки.Найти(СтрокаТаблицы[КлючСвязи], КлючСтроки,Истина);
Если СтрокаГруппировки = Неопределено Тогда
ЗаполнитьЗначенияСвойств(Дерево.Строки.Добавить(), СтрокаТаблицы);
Иначе
ЗаполнитьЗначенияСвойств(СтрокаГруппировки.Строки.Добавить(), СтрокаТаблицы);
КонецЕсли;
КонецЦикла;

Возврат Дерево.Скопировать();

КонецФункции //ВыгрузитьТаблицуЗначенийВДеревоЗначений()

Пример интеграции 1С с API (chat-api.com) для WhatsUp

Отправка сообщения из 1С в группу чата WhatsUp:

Сервер = e*70.c*at-a*i.c*m;
Ресурс = /ins*ance1*6473/sendMessage?token=ry*q7*m5l*ka*6m;
ContentType = application/json; charset=utf-8;

ТекстСообщения = «»»Тестовое сообщение из 1С, дата отправки: » +ТекущаяДата()+«»»»;

Тело =
«{«»chatId»»:»»»+791*29*74*1-1*96*66135@g.us+«»»,»»body»»:»+ТекстСообщения+«}»;
// chatId получаем в результате запроса последних сообщений в группе, например через браузерную строку

Попытка
ЗаголовокHTTP = Новый Соответствие();
//Все параметры подключения
HTTPСоединение = Новый HTTPСоединение(Сервер,,,,,);
HTTPЗапрос = Новый HTTPЗапрос(Ресурс, ЗаголовокHTTP);
HTTPЗапрос.Заголовки.Вставить(«Content-type», ContentType);
HTTPЗапрос.УстановитьТелоИзСтроки(Тело,»UTF-8″);
HTTPОтвет =
HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
КодСостояния = HTTPОтвет.КодСостояния;
ТекстОтвета = HTTPОтвет.ПолучитьТелоКакСтроку();
Ответ = «»;
Ответ = Ответ + «Код состояниия (Status code): » + Символы.ПС;
Ответ = Ответ + КодСостояния + Символы.ПС +«————————» +Символы.ПС;
Ответ = Ответ + «Текст ответа (Response text): » + Символы.ПС;
Ответ = Ответ + ТекстОтвета;

ОчиститьСообщения();
Сообщить(Ответ);
Исключение
Сообщить(«Произошла ошибка при подключении: »
+ ОписаниеОшибки());
КонецПопытки;